sábado, 14 de septiembre de 2013

MOD RGB Master System II

Entradas relacionadas:  MOD LED-50/60-AV      MOD LED bicolor-50/60/AV
                                    MOD LED-50/60-RGB   MOD LED-50/60-RGB Placa


Anteriormente he publicado el MOD de AV de las Master II, ahora he efectuado una con salida RGB, ya que la consola tiene las señales, pero no las saca al exterior. Habitualmente he visto que se instala un conector igual al de la Master System I, así el mismo cable sirve para las dos consolas, pero como no era este el caso, he puesto un Euroconector en la caja, y así lo enchufas directamente con cualquier cable.

La señal de AV se ve mucho mejor que la de RF, incluso con mejor color, pero he de decir que la mejora de calidad de imagen en RGB sobre AV es espectacular, los colores son igual de buenos, pero la nitidez y los detalles son mucho mas finos.


He cambiado la ubicación del led de encendido, lo he puesto en el interior del interruptor en lugar de en el lateral, así se ve apagado Y así encendida la consola. No he puesto el led bicolor por falta de espacio, solo cabe uno muy pequeño dentro.
El Euroconector hembra ubicado y pegado en su lugar, en el lateral derecho hay mucho espacio para ponerlo. Junto a el he ubicado el interruptor de 50/60 Hz
 Este es el esquema a usar, no he puesto las salidas Y/C de SVideo, y el audio lo he sacado de las resistencias 19 y 20 en lugar de desde el chip, sin necesidad de poner el condensador de 10uF. Todos los condensadores son electrolíticos, el voltaje que deben soportar es el de las señales RGB y el sonido si los poneis, estas señales no llegan a 3 voltios, por lo que podeis usar condensados de 5 voltios sin problemas.  Así queda el conjunto, he puesto los condensadores y resistencias en una placa, y he llevado a ella todos los hilos. Acordaros que los Euroconectores tienen las salidas de sonido y la de AV cruzadas, por tanto hay que poner el sonido en 1 y 3 en lugar de en 2 y 6, mientras que el AV va en la 19 en lugar de en la 20. El cable verde de abajo es el que conmuta 50/0, y junto a el se ve el conector de encendido donde he puesto el LED.
De aquí salen los cables, solo he soldado el de AV directo en el chip, los otros van en puntos en la placa, a la derecha arriba el gris es masa y abajo el rosa los +5V Aquí están resistencias y condensadores, todos los cables llegan a esta placa, y de aquí van al euroconector a través de resistencia y condensador, o directos. También de aquí saco los +5v y masa para el MOD de 50/60
De aquí sale el cable para el MOD de 50/60, soldado a la pata que he levantado del chip. Vista del conmutador y el euroconector cableados, al centro el cable soldado a la pata del chip, a un lado +5Voltios y al otro masa.
Para ponerle la protección metálica para evitar interferencias, hay que doblarla en la parte trasera, levantando un poco en la zona izquierda para que pasen los cables por debajo sin problemas.
Alex a 50 Hz PAL, se aprecia el margen inferior de la pantalla grande Alex a 60Hz NTSC, el borde es mucho menor, la música y el juego se ven mas acelerados.
Comparación de la imagen por RF/AV/RGB
El juego por RF, poca nitidez, colores mas apagados
Por AV se aprecia la mejora de la imagen, mucho mas nítida, con colores mas contrastados.
Por RGB el cambio es espectacular, los colores siguen siendo mucho mas contrastados, pero la finura de los detalles en la imagen es sorprendente, las letras de Alex se aprecian que tienen un borde mucho mas fino.

Animaros a este MOD, el cambio en la calidad de imagen es espectacular, y no cuesta mucho hacerlo, podéis poner una placa o soldar directamente, encontrareis condensadores mas pequeños en las tiendas, estos que yo he puesto eran un poco gordos.



Si tenéis dudas, queréis hacer una consulta, o si queréis que os repare o modifique algo,
consultarme al mail, y haré lo posible  por ayudaros o reparar vuestros aparatos.

8 comentarios:

  1. Hola, No me pierdo con los esquemas y las fotos, pero tengo una duda, el cable rosa de +5V es la que va al pin 16 del euroconector de comutacion de RGB???

    Gracias!!!

    ResponderEliminar
    Respuestas
    1. He cread una nueva entrada con el circuito en placa de topos, y así creo que estará mas claro.

      Eliminar
  2. Javu, yo tengo un problema, ya hice el mod de 50/60 hz con led bicolor y sin problema, el tema es el siguiente:

    Le iba a hacer el mod de RGB con salida a euroconector, como el tuyo, pero el chip grafico es diferente, es un MB3514, no seria problema soldar, porque ya encontre por ay la ficha tecnica de que es cada patilla, pero no me fio mucho, Podrias aconsejarme que hacer??

    Gracias por tu tiempo! Un saludo!

    ResponderEliminar
    Respuestas
    1. El MB3514 tiene el mismo patillaje que el chip de Sony CXA1145, por lo que puedes sacar las señales de las mismas patillas.

      Eliminar
    2. UFFFFF!!! Muchisimas gracias Javu, Ya pense que no podria modearla!! Mañana mismo me pongo a ello!!

      Gracias de nuevo!

      Eliminar
  3. Hola amigo Javu, he estado haciendo todos estos mods a la consola y me he encontrado con unos problemas, te cuento. Para empezar, decidí no agujerear la carcasa de la consola por lo que para hacer el mod la única solución era sacar cables por algún orificio de la consola y hacer el mod en una caja externa. Eso lo resolví sin problemas. Para los cables que salen de la consola usé 3 USB con conexión hembra de este modo podría conectar y desconectar la caja cuando quisiera poniéndole a esta 3 USB macho. Quería hacer un MOD completo así que compré componentes para todos los MODS: LED bicolor, S-Video, Audio, RGB e incluso compré un conecto para sacar también el RF (ya que el orificio por donde salen mis cables es el RF y el conector queda totalmente inutilizado). Ahora que sabes el "tinglao" que he montado, te cuento el problema: Falla prácticamente todo!! A ver, el RGB (euroconector) funciona en algunos televisores, en otras no. El S-Video o AV no funciona en ningun televisor. El LED lo he visto funcionar en los televisores en los que funciona el RGB, aunque solo funciona uno de los dos colores. El RF he tenido que desoldarlo por que, aunque no lo use, si lo sueldo no se enciende la consola. He probado a hacer contacto con el cable en su sitio sin soldarlo y es tocar y apagarse la consola.

    No entiendo porque pasa esto, que yo sepa está todo bien. Lo único que me tiene en duda son los condensadores electrolíticos que son de 220uF pero son de 16v. Aunque he leído en varios sitios que esos valen. Había pensado que lo único que tiene en común todo es la masa, pero si no me equivoco la saqué de la patilla 24 del chip tal y como indicas. Que yo sepa todo está bien y no se muy bien que hacer. AYUDAME!!

    ResponderEliminar
    Respuestas
    1. Por cierto, también tengo duda con el S-Video, lo saqué de la patilla 20 de tu esquema usando resistencia y condensador, aunque por ahí lo hacen sin el condensador, pero creo que leí que no es necesaria aunque si es recomendable. Dudo que eso provoque el fallo del S-Video, pero es un dato más.

      Eliminar
  4. El tema del RGB depende de que reciba o no señal por la pata 16 del euroconector, y que la tele se active sola al recibir dicha señal, por eso en algunas va y en otras no. En las que no, en algunas se puede forzar a activar la entrada por euroconector, prueba si tu tele la tiene. Pero lo del LED que solo va en las que se ve parece indicar que tienes una derivación, asegurate de las conexiones, revisalas bien por si alguna hace algún contacto malo. Recuerda que el USB puede tener conectada la masa a la carcasa, y eso hacer que se produzca una derivación, no uses el conector de masa de los USB para otro cosa que no sea masa, para evitar el posible problema.

    El AV es el que menos problemas debe darte, asegurate de tener la masa en el conector redondo, y el condensador es opcional, prueba a ponerlo y quitarlo a ver que pasa. El RF que falla es señal de que tienes derivación, al final creo que debes revisar bien todo de nuevo.

    Los condensadores no son problema que sean de 16v, es lo habitual, esos te sirven perfectamente,

    ResponderEliminar